OSPF – Open Shorkiểm tra Path First là một giao thức định tuyến liên kết – state nổi bật. Đây là 1 trong những giao thức được sử dụng rộng thoải mái trong số mạng công ty bao gồm kích cỡ to. Mỗi router lúc chạy giao thức vẫn gửi những tinh thần đường link của nó cho toàn bộ những router vào vùng (area). Sau một thời gian thảo luận, các router đang đồng điệu được bảng cửa hàng tài liệu tâm lý mặt đường link (Link State Database – LSDB) với nhau, từng router đều phải có được bạn dạng vật dụng mạng của cả vùng. Từ kia mỗi router đã chạy lời giải Dijkstra tính toán thù ra một cây đường đi nđính nhất (Shordemo Path Tree) cùng phụ thuộc vào cây này nhằm xây hình thành bảng định con đường.

Bạn đang xem: Ospf là gì

1. Link State

Link State là giao thức kiến tạo đường đi tốt nhất (Shorchạy thử path first) trải qua lời giải Dijkstra. Các router chỉ việc hội đàm báo cáo của nhau qua gói tin Hello nhưng ko yêu cầu gửi cả bảng định tuyến. Sau lúc bao gồm biết tin nó sẽ xây dựng ra một bảng định tuyến cùng lối đi rất tốt.

Chỉ số AD: là chỉ số tin cẩn của những giao thức

Cost: là giá trị được tính theo phương pháp 10^8/Bandwidth

OSPF chạy xe trên nền IPhường còn RIP điều khiển xe trên giao thức UDP

Các gói tin IPhường vận cthị xã những gói tin OSPF thì trường Protocol- ID = 89

2. Cơ chế hoạt động vui chơi của giao thức OSPF

Router đuổi theo OSPF thì nó phải trải qua 4 bước:

Router ID

Thiết lập Neighbor

Trao thay đổi LSDB (Link State Database)

Xây dựng bảng định tuyến

a. Router ID là gì ?

Router IDđơn giản dễ dàng là một giá trị cần sử dụng định danh mang lại Router khi dùng giao thức OSPF

Có định hình của một cửa hàng IP. A.B.C.D. Có định hình là tác động IPhường chứ chưa phải là hệ trọng IP

Lấy IPhường cao nhấttrong cácInterface đang hoạt độngvàưu tiên cổng Loopbaông xã.

+ IPhường cao nhất: là can dự IP.. cao nhất. IPhường có octet đầu cao hơn được coi là phệ hơn

Vd: 1, 192.168.1.1,

2, 192.168.1.2, => là lớn số 1 (xét trường đoản cú 192, tiếp đến sang 168 kế tiếp sang một với sau cuối là 2)

3, 172.16.255.255,

4, 10.255.255.254.

Địa chỉ 2 > 1 > 3 > 4

Vậy ID của Router ở đấy là 192.168.1.2

+ Interface active: là cổng vẫn (up/up) Status up và protocol up.

+ Cổng Loopbaông chồng sẽ được ưu tiên rộng vì chưng nó không nhiều bị lỗi và bất biến.

b. Thiết lập quan hệ nam nữ bóng giềng

Các Router vẫn gửi gói tin Hello (10s/1 lần). Được dùng làm tìm thấy router bóng giềng, gửi một quan hệ tình dục láng giềng sang trạng thái 2 bước (2- Way), kế tiếp Hello góp đo lường và tính toán láng giếng Lúc nó bị lỗi.

Lần thứ nhất gói tin Hello gửi đến xúc tiến 224.0.0.6

2 Router cần vừa lòng những ĐK sau bắt đầu được Call là trơn giềng (đề nghị bảo đảm 5 thông tin):

=> Cùng Area-id: khi mạng béo fan ta chia làm những vùng, vùng nào lỗi thì chỉ vùng kia chịu đựng tác động. Mỗi một vùng đang đặt cho 1 Area-id. Vùng trung trung ương bao gồm Area-id buộc phải bởi 0. Mọi vùng không giống nên tất cả mặt đường truyền thẳng về vùng 0 nó mới truyền được dữ liệu.

=> Cùng Subnet: 2 ip nên thuộc Subnet mới ping và trao đổi được công bố.

=> Phải cùng thông số: Hello/Dead-time nghỉ ngơi trên 2 cổng. Mặc định Hello là 10s, Dead là 40s sau 40s nó sẻ hủy kết nối.

=> Phải thuộc Xác thực trên 2 cổng. Dành cho mạng to (metro). khi đặt bảo đảm các router khác không lấy được thông báo.

=> Phải cùng cờ Stub Area Flag: dành riêng cho OSPF đa vùng (học tập vào CCNP)

Để coi được láng giềng sử dụng lệnh: Show IPhường OSPF Neighbor

c. Trao đổi LSDB (Link State Database)

Mỗi Router những chưa một bảng LSDB

LSDP: Link State Database. Do nó béo vì thế nó phân tách nhỏ dại ra thành những phiên bản LSA nhằm gửi

LSA: Link State Advertisement. Để gửi được LSA thì nó buộc phải gói gọn vào bản tin LSU

LSU: là Link State Update. Để hội đàm và gửi được LSU thì nó tất cả 2 vẻ bên ngoài môi trường gửi:

- Point - lớn - Point: 2 router chạy cùng nhau theo giao thức HDLC hayPPP. Sau khi nó liên kết được láng giềng thì chỉ bao gồm 2 Router điều đình trực tiếp Call là Full

- Broadcast Multiaccess: là nhiều Router liên kết cùng nhau thông sang một Swtich. R1, R2, R3, R4 thuộc liên kết vào 1 Switch. Lúc này nó Bàn bạc LSDB sẽ khác hoàng toàn.

Trong 4 Router đã bầu ra một Router làm DR-Desigted Router, 3 router còn sót lại đang thai ra một BDR-Backup DR.

Các Router sót lại đang là DR Other. 2 Router là DR Other sẽ không còn gửi trực tiếp với nhau. Nó vẫn gửi lên tiếng về DR 1 bạn dạng với 1 bạn dạng mang đến BDR. Sau đó DR vẫn gửi phân phối xuống cho các Router còn sót lại.

DR Other đang gử công bố về DR bằng ảnh hưởng 224.0.0.6. DR đã gửi LSDB mang lại DR Other là 224.0.0.5.

Xem thêm: Lisp Cad Là Gì ? Hướng Dẫn Cài Lisp Cad 34 Lisp Autocad Hữu Ích Dành Cho Dân Thiết Kế

Tiêu chí như thế nào được bầu làm cho DR với BDR:

Trên mỗi cổng liên kết của những Router sẽ có một tmê man số: Priority(0-255) mang định là 1. Con nào cao nhất là DR với nhỏ làm sao rẻ rộng là BDR.

Câu lệnh: R(config)# int F0/1 => R(config -if)# ip ospf priority (0-255)

Nếu rủi ro có Priority là đều bằng nhau nó sẽ dựa vào Router - ID. Router tất cả Router-id tối đa là DR

Nếu hệ thống vẫn gồm DR cùng BDR giả dụ cắm thêm một Router mới có DR cao hơn nó vẫn ưu tiên DR vẫn vận động.

Nếu để Priority là 0 nó sẽ không còn thai DR tốt BDR

c. Xây dựng bảng định đường nó sử dụng lời giải Dijkstra để mang đi ra ngoài đường đi xuất sắc nhất

3. Cách tính Metric

Cost=10^8 /bandwidth

Băng thông bắt buộc thay đổi ra đối chọi vị: bps

Vd:

*

4. Cấu hình

a. Wildcard mask

Wildthẻ masklà một trong cách thức lấy ra tương tác IPhường của một dải rất thiêng hoạt. Nó là một trong hàng nhị phân 32 bit được sử dụng kèm với cùng 1 cửa hàng IPhường tham chiếu làm sao đó. Bit của tương tác IP khớp ứng với Bit 0 là thắt chặt và cố định, bit của IP khớp ứng với bit 1 đã cố định.

Vd: 192.168.1.0/24

Ta có: IP:192.168.1.0

WCM: 0 . 0 . 0.255

Vd: 192.168.1.32/27

Ta có: IP: 192.168.1.001xxxxx

WCM: 0 . 0 . 0 .00011111 => 0.0.0.31

b. Các lệnh cấu hình

Chạy OSPF

R(config)# Router OSPF Process-id (1-65535) chỉ tất cả chân thành và ý nghĩa nội cỗ.

R(config-Router)# network 192.168.1.0 0.0.0.31 area 0 (Areal là cùng mạng nhân tố này khôn xiết quan lại trọng)

R(config-Router)#default-information originate

Router(config-router)#redistribute connected subnet.

Hiệu chỉnh OSPF

Router - ID:

R(config)# Router OSPF 10

R(config-router)# router-id a.b.c.d (nhập ip vào, IP. đó là ID)

Sau đó trsinh sống ra mode quản lí trị:

R(config)# Clear ip ospf process thì nó bắt đầu gồm hiệu lực

Priority:

R(config)# int f0/0

R(config-if)# ip ospf priority

Hello/Dead time:

R(config-if)# ip ospf hello-interval thời hạn (là giây)

R(config-if)# ip ospf dead-interval thời hạn (là giây)

Xác thực bên trên 2 router

Vào vào cổng:

R(config-if)# ip ospf authentiacation

Nếu điền key:

R(config-if)# ip ospf authentiacation-key aptech

Các lệnh Show

Show ip router ospf

Show ip ospf neighbor

Show ip ospf database

Show ip ospf interface

Show ip protocol

5. Crúc ý

Dùng lệnh Show ip router:

10.0.0.0/24 is subnetted, 1 subnets

O E2 10.0.0.0 <110/20> via 192.168.1.đôi mươi, 00:00:53, Serial0/1/0 => tương xứng #redistribute connected subnet.

C 192.168.1.0/24 is directly connected, Serial0/1/0

C 192.168.2.0/24 is directly connected, FastEthernet0/0

O 192.168.3.0/24 <110/65> via 192.168.1.20, 00:00:53, Serial0/1/0

O*E2 0.0.0.0/0 <110/1> via 192.168.1.20, 00:00:11, Serial0/1/0 => tương ứng: #default-information originate

II.Single-area cùng Multi-area OSPF

1. Cấu hình Single-area OSPF

a. Chạy OSPF

R(config)# Router OSPF Process-id (1-65535) chỉ có chân thành và ý nghĩa nội cỗ.

R(config-Router)# network 192.168.1.0 0.0.0.31 area 0 (Areal là thuộc mạng thành phần này cực kỳ quan liêu trọng)

R(config-Router)#default-information originate

Router(config-router)#redistribute connected subnet.

b. Hiệu chỉnh OSPF

Router - ID

R(config)# Router OSPF 10

R(config-router)# router-id a.b.c.d (nhập ip vào, IPhường. đó là ID)

Sau đó trsinh hoạt ra mode quản lí trị:

R(config)# Clear ip ospf process thì nó mới gồm hiệu lực

Priority

R(config)# int f0/0

R(config-if)# ip ospf priority

Hello/Dead time

R(config-if)# ip ospf hello-interval thời hạn (là giây)

R(config-if)# ip ospf dead-interval thời gian (là giây)

c. Xác thực bên trên 2 router

Vào vào cổng:

R(config-if)# ip ospf authentiacation

Nếu điền key:

R(config-if)# ip ospf authentiacation-key aptech

d. Các lệnh Show

Show ip router ospf

Show ip ospf neighbor

Show ip ospf database

Show ip ospf interface

Show ip protocol

2. Cấu hình Multi-area OSPF

a. thông số kỹ thuật Multi-area

Router(config)#router ospf 5

Router(config-router)#redistribute ospf 10 subnet

b. Redistribute vào OSPF

RIP.. => OSPF

Router(config)#router ospf process-id

Router(config-router)#redistribute rip subnet.

EIGRP-OSPF

Router(config-router)#redistribute eigrp as-number subnet.

Static route & Default route => OSPF

Router(config-router)#redistribute static subnet.

Connected route => EIGRP

Router(config-router)#redistribute connected subnet.

Default route => OSPF

Router(config-router)#default-information originate.

Nếu chúng ta ko đưa vào tđắm say số metric thì mang định metric sẽ được đặt cho đường được redistribute vào là trăng tròn.

Xem thêm: Đơn Vị Lb Là Gì - Chuyển Đổi Đơn Vị Lbs

3. Chụ ý

Dùng lệnh Show ip router:

10.0.0.0/24 is subnetted, 1 subnets

O E2 10.0.0.0 <110/20> via 192.168.1.đôi mươi, 00:00:53, Serial0/1/0 => tương ứng #redistribute connected subnet.

C 192.168.1.0/24 is directly connected, Serial0/1/0

C 192.168.2.0/24 is directly connected, FastEthernet0/0

O 192.168.3.0/24 <110/65> via 192.168.1.trăng tròn, 00:00:53, Serial0/1/0

O*E2 0.0.0.0/0 <110/1> via 192.168.1.20, 00:00:11, Serial0/1/0 => tương ứng: #default-information originate


Chuyên mục: Blog